トップページ -> 情報工学,情報スキルの教材 -> Ruby プログラミング -> Ruby で VoltDB を動かす
[サイトマップへ]  

Ruby で VoltDB を動かす (書きかけ)

2010/05/30 時点では, voltrb は VoltDB バージョン 1.2 系列では動きますが、 voltrb は VoltDB バージョン 1.3 系列では動かないのでご注意下さい。

前準備


VoltDB のデータ型


voltrb のインストール

■ Ubuntu 11.04での操作手順例

sudo apt-get install libruby
# または sudo apt-get install libruby1.9.1

sudo gem install rubyrb

  • Ruby サンプルプログラム

    require 'rubygems'
    require 'voltrb'
    
    client = VoltRb::Client.new( {:host => "localhost", :port => 21212, :username = "hoge", password = "none" );
    id = 101
    item = 1000
    response = client.call_procedure("Insert", id, item)